Maven Java аннотацияларын құрастырмайды?

Java аңдатпаларын пайдаланатын жобаны жасау үшін maven алуда қиындық туды. Мен келесі қате туралы хабарды аламын:

annotations are not supported in -source 1.3 (use -source 5 or higher to enable annotations)
@PostConstruct

Менің POM-де келесі компилятор плагині бар, сондықтан бастау үшін ол қайда келеді-1.3-ші қорды?

        
            org.apache.maven.plugins
            maven-compiler-plugin
            2.3.2
            
                1.6
                1.6
            
        

Мен бұл жұмысты алу үшін өте қарапайым нәрсе болмады деп күдіктенемін, бірақ қателіктер ештеңе пайда болмайды

Кез келген көмекті қатты бағалайтын болар еді

2
Бұл плагин үшін дұрыс xml 1.6 қамтамасыз етеді. Мәселе сіз бізді көрсетпейтін бөлікте немесе бұл орын дұрыс емес жерде орналасқан.
қосылды автор Brian Roach, көзі
@RobV, жоқ, бұл Maven мәселесі емес. Ол миллиондаған басқа әзірлеушілер үшін тамаша жұмыс істейді. Егер сіз POM-ті жібере алмасаңыз, мұнда ешкім дұрыс емес әрекеттерді табуыңызға көмектесе алмайды. Егер 3.x нұсқасына жаңарту сәтсіздікті түзетсе, онда POM-ді өшіретін maven2 теңшелімінде бірдеңе бар.
қосылды автор Brian Roach, көзі
Иә, бұл құрылыста/плагиндер бөлімінде, құпиялылық себептері бойынша бүкіл POM-ды көрсете алмаймын. Maven 2-ке қарсы Maven 2-ге қарсы таңғажайып жаңарту бұл мәселені POM мәселесі емес, Maven деп шешеді?
қосылды автор RobV, көзі
Толық помаңызды көшіруіңіз керек, басқа жерде конфигурациялық мәселе бар. Аннотацияны пайдаланып, бір сыныптан басқа ештеңе жоқ, ең аз мөлшерде бастауды ұсынуға тырысамын. Егер ол болса, онда басқа компоненттерді біртіндеп, жұмыс істемейінше біртіндеп қосыңыз. Сен кінәлі екенсің.
қосылды автор Guillaume, көзі
- бұл плагиндердегі құрастыру помприты?
қосылды автор smp7d, көзі

1 жауаптар

Make sure that your element is inside section and not only in or sections.

2
қосылды